Integer Overflow or Wraparound Affecting glib2.0 package, versions <2.74.6-2+deb12u6


Severity

Recommended
0.0
low
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.66% (52nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-GLIB20-9668972
  • published8 Apr 2025
  • disclosed7 Apr 2025

Introduced: 7 Apr 2025

CVE-2025-3360  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Debian:12 glib2.0 to version 2.74.6-2+deb12u6 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream glib2.0 package and not the glib2.0 package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

A flaw was found in GLib. An integer overflow and buffer under-read occur when parsing a long invalid ISO 8601 timestamp with the g_date_time_new_from_iso8601() function.

CVSS Base Scores

version 3.1