CRLF Injection Affecting gvfs package, versions <1.50.3-1+deb12u1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.42% (37th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-GVFS-15358595
  • published27 Feb 2026
  • disclosed26 Feb 2026

Introduced: 26 Feb 2026

CVE-2026-28296  (opens in a new tab)
CWE-93  (opens in a new tab)

How to fix?

Upgrade Debian:12 gvfs to version 1.50.3-1+deb12u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gvfs package and not the gvfs package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

A flaw was found in the FTP GVfs backend. A remote attacker could exploit this input validation vulnerability by supplying specially crafted file paths containing carriage return and line feed (CRLF) sequences. These unsanitized sequences allow the attacker to terminate intended FTP commands and inject arbitrary FTP commands, potentially leading to arbitrary code execution or other severe impacts.

CVSS Base Scores

version 3.1