OS Command Injection Affecting leptonlib package, versions <1.75.3-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.43% (72nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-LEPTONLIB-1549549
  • published24 Apr 2018
  • disclosed24 Apr 2018

Introduced: 24 Apr 2018

CVE-2018-3836  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade Debian:12 leptonlib to version 1.75.3-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream leptonlib package and not the leptonlib package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

An exploitable command injection vulnerability exists in the gplotMakeOutput function of Leptonica 1.74.4. A specially crafted gplot rootname argument can cause a command injection resulting in arbitrary code execution. An attacker can provide a malicious path as input to an application that passes attacker data to this function to trigger this vulnerability.

CVSS Base Scores

version 3.1