Out-of-Bounds Affecting libmatio package, versions <1.5.23-2+deb12u1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.56% (46th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-LIBMATIO-9465020
  • published18 Mar 2025
  • disclosed16 Mar 2025

Introduced: 16 Mar 2025

CVE-2025-2338  (opens in a new tab)
CWE-119  (opens in a new tab)
CWE-122  (opens in a new tab)

How to fix?

Upgrade Debian:12 libmatio to version 1.5.23-2+deb12u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libmatio package and not the libmatio package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

A vulnerability, which was classified as critical, was found in tbeu matio 1.5.28. Affected is the function strdup_vprintf of the file src/io.c. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used.

CVSS Base Scores

version 3.1