NULL Pointer Dereference Affecting libsass package, versions <3.6.3-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.84% (79th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-LIBSASS-1550973
  • published3 Dec 2018
  • disclosed3 Dec 2018

Introduced: 3 Dec 2018

CVE-2018-19797  (opens in a new tab)
CWE-476  (opens in a new tab)

How to fix?

Upgrade Debian:12 libsass to version 3.6.3-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsass package and not the libsass package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

In LibSass 3.5.5, a NULL Pointer Dereference in the function Sass::Selector_List::populate_extends in SharedPtr.hpp (used by ast.cpp and ast_selectors.cpp) may cause a Denial of Service (application crash) via a crafted sass input file.