Use After Free Affecting lua5.4 package, versions <5.4.1-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.44% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-LUA54-1553300
  • published26 Jul 2020
  • disclosed21 Jul 2020

Introduced: 21 Jul 2020

CVE-2020-15888  (opens in a new tab)
CWE-416  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade Debian:12 lua5.4 to version 5.4.1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lua5.4 package and not the lua5.4 package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

Lua through 5.4.0 mishandles the interaction between stack resizes and garbage collection, leading to a heap-based buffer overflow, heap-based buffer over-read, or use-after-free.

CVSS Base Scores

version 3.1