SQL Injection Affecting mapserver package, versions <8.0.0-3+deb12u1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.42% (35th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-MAPSERVER-12979056
  • published20 Sept 2025
  • disclosed19 Sept 2025

Introduced: 19 Sep 2025

CVE-2025-59431  (opens in a new tab)
CWE-89  (opens in a new tab)

How to fix?

Upgrade Debian:12 mapserver to version 8.0.0-3+deb12u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mapserver package and not the mapserver package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

MapServer is a system for developing web-based GIS applications. Prior to 8.4.1, the XML Filter Query directive PropertyName is vulnerably to Boolean-based SQL injection. It seems like expression checking is bypassed by introducing double quote characters in the PropertyName. Allowing to manipulate backend database queries. This vulnerability is fixed in 8.4.1.

CVSS Base Scores

version 3.1