Use After Free Affecting mruby package, versions <1.4.0+20180418+git54905e98-1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.26% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-MRUBY-1554301
  • published18 Apr 2018
  • disclosed18 Apr 2018

Introduced: 18 Apr 2018

CVE-2018-10199  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Debian:12 mruby to version 1.4.0+20180418+git54905e98-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mruby package and not the mruby package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

In versions of mruby up to and including 1.4.0, a use-after-free vulnerability exists in src/io.c::File#initilialize_copy(). An attacker that can cause Ruby code to be run can possibly use this to execute arbitrary code.