Improper Input Validation Affecting nautilus package, versions <3.25.90-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.47% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-NAUTILUS-1554285
  • published20 Sept 2017
  • disclosed20 Sept 2017

Introduced: 20 Sep 2017

CVE-2017-14604  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:12 nautilus to version 3.25.90-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nautilus package and not the nautilus package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

GNOME Nautilus before 3.23.90 allows attackers to spoof a file type by using the .desktop file extension, as demonstrated by an attack in which a .desktop file's Name field ends in .pdf but this file's Exec field launches a malicious "sh -c" command. In other words, Nautilus provides no UI indication that a file actually has the potentially unsafe .desktop extension; instead, the UI only shows the .pdf extension. One (slightly) mitigating factor is that an attack requires the .desktop file to have execute permission. The solution is to ask the user to confirm that the file is supposed to be treated as a .desktop file, and then remember the user's answer in the metadata::trusted field.

CVSS Base Scores

version 3.1