Arbitrary Argument Injection Affecting network-manager-l2tp package, versions <1.20.8-1+deb12u1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.15% (4th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-NETWORKMANAGERL2TP-19888505
  • published18 Sept 2026
  • disclosed17 Sept 2026

Introduced: 17 Sep 2026

CVE-2026-93337  (opens in a new tab)
CWE-88  (opens in a new tab)

How to fix?

Upgrade Debian:12 network-manager-l2tp to version 1.20.8-1+deb12u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream network-manager-l2tp package and not the network-manager-l2tp package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

NetworkManager-l2tp through 1.52.4, fixed in 1.52.6, contains an improper input validation vulnerability that allows local users with VPN connection creation permissions to inject arbitrary pppd directives by supplying mru or mtu property values containing trailing non-numeric content after a valid integer. Attackers can exploit the verbatim write of unvalidated strings into the pppd options file via write_config_option() to inject the plugin directive, causing the privileged pppd process to load an attacker-controlled shared object and achieve arbitrary code execution as root.

CVSS Base Scores

version 3.1