Memory Leak Affecting opencv package, versions <4.6.0+dfsg-12


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.3% (67th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-OPENCV-5518065
  • published11 May 2023
  • disclosed10 May 2023

Introduced: 10 May 2023

CVE-2023-2618  (opens in a new tab)
CWE-401  (opens in a new tab)

How to fix?

Upgrade Debian:12 opencv to version 4.6.0+dfsg-12 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream opencv package and not the opencv package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

A vulnerability, which was classified as problematic, has been found in OpenCV wechat_qrcode Module up to 4.7.0. Affected by this issue is the function DecodedBitStreamParser::decodeHanziSegment of the file qrcode/decoder/decoded_bit_stream_parser.cpp. The manipulation leads to memory leak. The attack may be launched remotely. The name of the patch is 2b62ff6181163eea029ed1cab11363b4996e9cd6. It is recommended to apply a patch to fix this issue. The identifier of this vulnerability is VDB-228548.

CVSS Base Scores

version 3.1