Cryptographic Issues Affecting opensaml package, versions <3.0.0-2


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.89% (55th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-OPENSAML-1555913
  • published29 Sept 2009
  • disclosed29 Sept 2009

Introduced: 29 Sep 2009

CVE-2009-3475  (opens in a new tab)
CWE-310  (opens in a new tab)

How to fix?

Upgrade Debian:12 opensaml to version 3.0.0-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream opensaml package and not the opensaml package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

Internet2 Shibboleth Service Provider software 1.3.x before 1.3.3 and 2.x before 2.2.1, when using PKIX trust validation, does not properly handle a '\0' character in the subject or subjectAltName fields of a certificate, which allows remote man-in-the-middle attackers to spoof arbitrary SSL servers via a crafted certificate issued by a legitimate Certification Authority, a related issue to CVE-2009-2408.

CVSS Base Scores

version 3.1