XML External Entity (XXE) Injection Affecting owslib package, versions <0.27.2-3


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.98% (61st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-OWSLIB-3357959
  • published9 Mar 2023
  • disclosed8 Mar 2023

Introduced: 8 Mar 2023

CVE-2023-27476  (opens in a new tab)
CWE-611  (opens in a new tab)

How to fix?

Upgrade Debian:12 owslib to version 0.27.2-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream owslib package and not the owslib package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

OWSLib is a Python package for client programming with Open Geospatial Consortium (OGC) web service interface standards, and their related content models. OWSLib's XML parser (which supports both lxml and xml.etree) does not disable entity resolution, and could lead to arbitrary file reads from an attacker-controlled XML payload. This affects all XML parsing in the codebase. This issue has been addressed in version 0.28.1. All users are advised to upgrade. The only known workaround is to patch the library manually. See GHSA-8h9c-r582-mggc for details.

CVSS Base Scores

version 3.1