Improper Encoding or Escaping of Output Affecting php-twig package, versions <3.5.1-1+deb12u3


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.3% (22nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-PHPTWIG-16896264
  • published27 May 2026
  • disclosed14 Jul 2026

Introduced: 27 May 2026

CVE-2026-46628  (opens in a new tab)
CWE-116  (opens in a new tab)

How to fix?

Upgrade Debian:12 php-twig to version 3.5.1-1+deb12u3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php-twig package and not the php-twig package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

Twig is a template language for PHP. Prior to 3.26.0, the deprecated spaceless filter is registered as safe for HTML, causing Twig autoescaping to emit attacker-controlled markup unescaped when spaceless is applied to untrusted input. This issue is fixed in version 3.26.0.

CVSS Base Scores

version 3.1