Improper Input Validation Affecting ppp package, versions <2.4.7-2+3


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.87% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-PPP-1557661
  • published14 Jun 2018
  • disclosed14 Jun 2018

Introduced: 14 Jun 2018

CVE-2018-11574  (opens in a new tab)
CWE-20  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Debian:12 ppp to version 2.4.7-2+3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ppp package and not the ppp package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

Improper input validation together with an integer overflow in the EAP-TLS protocol implementation in PPPD may cause a crash, information disclosure, or authentication bypass. This implementation is distributed as a patch for PPPD 0.91, and includes the affected eap.c and eap-tls.c files. Configurations that use the refuse-app option are unaffected.

CVSS Base Scores

version 3.1