Memory Leak Affecting privoxy package, versions <3.0.33-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.44% (73rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-PRIVOXY-2314120
  • published10 Dec 2021
  • disclosed23 Dec 2021

Introduced: 10 Dec 2021

CVE-2021-44541  (opens in a new tab)
CWE-401  (opens in a new tab)

How to fix?

Upgrade Debian:12 privoxy to version 3.0.33-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream privoxy package and not the privoxy package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

A vulnerability was found in Privoxy which was fixed in process_encrypted_request_headers() by freeing header memory when failing to get the request destination.

CVSS Base Scores

version 3.1