Information Exposure Through Log Files Affecting puppetdb package, versions <7.11.2-2


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.74% (50th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-PUPPETDB-3153506
  • published4 Sept 2021
  • disclosed30 Aug 2021

Introduced: 30 Aug 2021

CVE-2021-27019  (opens in a new tab)
CWE-532  (opens in a new tab)

How to fix?

Upgrade Debian:12 puppetdb to version 7.11.2-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream puppetdb package and not the puppetdb package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

PuppetDB logging included potentially sensitive system information.

CVSS Base Scores

version 3.1