SQL Injection Affecting puppetdb package, versions <7.11.2-2


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.26% (66th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-PUPPETDB-3153509
  • published27 Jun 2021
  • disclosed20 Jul 2021

Introduced: 27 Jun 2021

CVE-2021-27021  (opens in a new tab)
CWE-89  (opens in a new tab)

How to fix?

Upgrade Debian:12 puppetdb to version 7.11.2-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream puppetdb package and not the puppetdb package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

A flaw was discovered in Puppet DB, this flaw results in an escalation of privileges which allows the user to delete tables via an SQL query.

CVSS Base Scores

version 3.1