OS Command Injection Affecting pygments package, versions <2.0.1+dfsg-2


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
6.72% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-PYGMENTS-1557990
  • published8 Jan 2016
  • disclosed8 Jan 2016

Introduced: 8 Jan 2016

CVE-2015-8557  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade Debian:12 pygments to version 2.0.1+dfsg-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pygments package and not the pygments package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

The FontManager._get_nix_font_path function in formatters/img.py in Pygments 1.2.2 through 2.0.2 allows remote attackers to execute arbitrary commands via shell metacharacters in a font name.

CVSS Base Scores

version 3.1