Use of a Broken or Risky Cryptographic Algorithm Affecting python-rsa package, versions <4.7.2-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.43% (73rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-PYTHONRSA-1557849
  • published2 Jun 2020
  • disclosed1 Jun 2020

Introduced: 1 Jun 2020

CVE-2020-13757  (opens in a new tab)
CWE-327  (opens in a new tab)

How to fix?

Upgrade Debian:12 python-rsa to version 4.7.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python-rsa package and not the python-rsa package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

Python-RSA before 4.1 ignores leading '\0' bytes during decryption of ciphertext. This could conceivably have a security-relevant impact, e.g., by helping an attacker to infer that an application uses Python-RSA, or if the length of accepted ciphertext affects application behavior (such as by causing excessive memory allocation).

CVSS Base Scores

version 3.1