Improper Input Validation Affecting python-rsa package, versions <3.2.3-1.1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
7.05% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-PYTHONRSA-1558032
  • published13 Jan 2016
  • disclosed13 Jan 2016

Introduced: 13 Jan 2016

CVE-2016-1494  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:12 python-rsa to version 3.2.3-1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python-rsa package and not the python-rsa package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

The verify function in the RSA package for Python (Python-RSA) before 3.3 allows attackers to spoof signatures with a small public exponent via crafted signature padding, aka a BERserk attack.