Arbitrary Code Injection Affecting python-uvicorn package, versions <0.13.3-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.36% (69th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-PYTHONUVICORN-1557781
  • published30 Aug 2020
  • disclosed27 Jul 2020

Introduced: 27 Jul 2020

CVE-2020-7694  (opens in a new tab)
CWE-74  (opens in a new tab)

How to fix?

Upgrade Debian:12 python-uvicorn to version 0.13.3-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python-uvicorn package and not the python-uvicorn package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

This affects all versions of package uvicorn. The request logger provided by the package is vulnerable to ASNI escape sequence injection. Whenever any HTTP request is received, the default behaviour of uvicorn is to log its details to either the console or a log file. When attackers request crafted URLs with percent-encoded escape sequences, the logging component will log the URL after it's been processed with urllib.parse.unquote, therefore converting any percent-encoded characters into their single-character equivalent, which can have special meaning in terminal emulators. By requesting URLs with crafted paths, attackers can: * Pollute uvicorn's access logs, therefore jeopardising the integrity of such files. * Use ANSI sequence codes to attempt to interact with the terminal emulator that's displaying the logs (either in real time or from a file).

CVSS Base Scores

version 3.1