Interpretation Conflict Affecting ruby3.1 package, versions <3.1.2-4


0.0
high

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
8.8 high
Expand this section
Red Hat
8.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN12-RUBY31-3148070
  • published 25 Nov 2022
  • disclosed 18 Nov 2022

How to fix?

Upgrade Debian:12 ruby3.1 to version 3.1.2-4 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream ruby3.1 package. See How to fix? for Debian:12 relevant versions.

The cgi gem before 0.1.0.2, 0.2.x before 0.2.2, and 0.3.x before 0.3.5 for Ruby allows HTTP response splitting. This is relevant to applications that use untrusted user input either to generate an HTTP response or to create a CGI::Cookie object.