CVE-2021-28834 Affecting ruby-kramdown package, versions <2.3.0-5


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.7% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-RUBYKRAMDOWN-1558887
  • published20 Mar 2021
  • disclosed19 Mar 2021

Introduced: 19 Mar 2021

CVE-2021-28834  (opens in a new tab)

How to fix?

Upgrade Debian:12 ruby-kramdown to version 2.3.0-5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-kramdown package and not the ruby-kramdown package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

Kramdown before 2.3.1 does not restrict Rouge formatters to the Rouge::Formatters namespace, and thus arbitrary classes can be instantiated.

CVSS Base Scores

version 3.1