Directory Traversal Affecting ruby-mail package, versions <2.4.4-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
4.92% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-RUBYMAIL-1558890
  • published18 Jul 2012
  • disclosed18 Jul 2012

Introduced: 18 Jul 2012

CVE-2012-2139  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Debian:12 ruby-mail to version 2.4.4-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-mail package and not the ruby-mail package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

Directory traversal vulnerability in lib/mail/network/delivery_methods/file_delivery.rb in the Mail gem before 2.4.4 for Ruby allows remote attackers to read arbitrary files via a .. (dot dot) in the to parameter.

CVSS Base Scores

version 3.1