Cross-site Scripting (XSS) Affecting ruby-redcloth package, versions <4.2.9-4


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.25% (81st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-RUBYREDCLOTH-1559195
  • published8 Jan 2015
  • disclosed8 Jan 2015

Introduced: 8 Jan 2015

CVE-2012-6684  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Debian:12 ruby-redcloth to version 4.2.9-4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-redcloth package and not the ruby-redcloth package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

Cross-site scripting (XSS) vulnerability in the RedCloth library 4.2.9 for Ruby and earlier allows remote attackers to inject arbitrary web script or HTML via a javascript: URI.

CVSS Base Scores

version 3.1