Integer Overflow or Wraparound Affecting rust-bzip2 package, versions <0.4.4-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.25% (70th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-RUSTBZIP2-3227866
  • published11 Jan 2023
  • disclosed10 Jan 2023

Introduced: 10 Jan 2023

CVE-2023-22895  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Debian:12 rust-bzip2 to version 0.4.4-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rust-bzip2 package and not the rust-bzip2 package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

The bzip2 crate before 0.4.4 for Rust allow attackers to cause a denial of service via a large file that triggers an integer overflow in mem.rs. NOTE: this is unrelated to the https://crates.io/crates/bzip2-rs product.

CVSS Base Scores

version 3.1