Directory Traversal Affecting sigil package, versions <0.9.16+dfsg-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.69% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-SIGIL-1559921
  • published1 Aug 2019
  • disclosed31 Jul 2019

Introduced: 31 Jul 2019

CVE-2019-14452  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Debian:12 sigil to version 0.9.16+dfsg-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream sigil package and not the sigil package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

Sigil before 0.9.16 is vulnerable to a directory traversal, allowing attackers to write arbitrary files via a ../ (dot dot slash) in a ZIP archive entry that is mishandled during extraction.