Improper Input Validation Affecting simplesamlphp package, versions <1.14.15-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.37% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-SIMPLESAMLPHP-1559517
  • published1 Sept 2017
  • disclosed1 Sept 2017

Introduced: 1 Sep 2017

CVE-2017-12869  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:12 simplesamlphp to version 1.14.15-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream simplesamlphp package and not the simplesamlphp package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

The multiauth module in SimpleSAMLphp 1.14.13 and earlier allows remote attackers to bypass authentication context restrictions and use an authentication source defined in config/authsources.php via vectors related to improper validation of user input.