Improper Input Validation Affecting teeworlds package, versions <0.7.0-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.94% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-TEEWORLDS-1560540
  • published21 Oct 2018
  • disclosed20 Oct 2018

Introduced: 20 Oct 2018

CVE-2018-18541  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:12 teeworlds to version 0.7.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream teeworlds package and not the teeworlds package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

In Teeworlds before 0.6.5, connection packets could be forged. There was no challenge-response involved in the connection build up. A remote attacker could send connection packets from a spoofed IP address and occupy all server slots, or even use them for a reflection attack using map download packets.