Numeric Errors Affecting bettercap package, versions <2.33.0-1+deb13u1


Severity

Recommended
0.0
low
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.39% (33rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-BETTERCAP-16718708
  • published17 May 2026
  • disclosed11 May 2026

Introduced: 11 May 2026

CVE-2026-8276  (opens in a new tab)
CWE-189  (opens in a new tab)
CWE-192  (opens in a new tab)

How to fix?

Upgrade Debian:13 bettercap to version 2.33.0-1+deb13u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream bettercap package and not the bettercap package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

A flaw has been found in bettercap up to 2.41.5. Affected by this issue is some unknown functionality of the file modules/mysql_server/mysql_server.go of the component MySQL Server. Executing a manipulation can lead to integer coercion error. The attack can be launched remotely. The attack requires a high level of complexity. The exploitation is known to be difficult. The exploit has been published and may be used. This patch is called 0eaa375c5e5446bfba94a290eff92967a5deac9e. It is advisable to implement a patch to correct this issue.

CVSS Base Scores

version 3.1