Buffer Overflow Affecting brotli package, versions <1.0.9-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.22% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-BROTLI-5675940
  • published16 Sept 2020
  • disclosed15 Sept 2020

Introduced: 15 Sep 2020

CVE-2020-8927  (opens in a new tab)
CWE-120  (opens in a new tab)
CWE-130  (opens in a new tab)

How to fix?

Upgrade Debian:13 brotli to version 1.0.9-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream brotli package and not the brotli package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

A buffer overflow exists in the Brotli library versions prior to 1.0.8 where an attacker controlling the input length of a "one-shot" decompression request to a script can trigger a crash, which happens when copying over chunks of data larger than 2 GiB. It is recommended to update your Brotli library to 1.0.8 or later. If one cannot update, we recommend to use the "streaming" API as opposed to the "one-shot" API, and impose chunk size limits.

References

CVSS Base Scores

version 3.1