Out-of-Bounds Affecting brotli package, versions <0.3.0+dfsg-3


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.35% (71st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-BROTLI-5675946
  • published14 Feb 2016
  • disclosed14 Feb 2016

Introduced: 14 Feb 2016

CVE-2016-1624  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Debian:13 brotli to version 0.3.0+dfsg-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream brotli package and not the brotli package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

Integer underflow in the ProcessCommandsInternal function in dec/decode.c in Brotli, as used in Google Chrome before 48.0.2564.109, allows remote attackers to cause a denial of service (buffer overflow) or possibly have unspecified other impact via crafted data with brotli compression.

CVSS Base Scores

version 3.1