Numeric Errors Affecting brotli package, versions <0.3.0+dfsg-3


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
4.14% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-BROTLI-5676110
  • published13 Mar 2016
  • disclosed13 Mar 2016

Introduced: 13 Mar 2016

CVE-2016-1968  (opens in a new tab)
CWE-189  (opens in a new tab)

How to fix?

Upgrade Debian:13 brotli to version 0.3.0+dfsg-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream brotli package and not the brotli package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

Integer underflow in Brotli, as used in Mozilla Firefox before 45.0, allows remote attackers to execute arbitrary code or cause a denial of service (buffer overflow) via crafted data with brotli compression.

CVSS Base Scores

version 3.1