Improper Authentication Affecting condor package, versions <7.8.2~dfsg.1-1+deb7u1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.18% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-CONDOR-6150727
  • published11 Jan 2024
  • disclosed28 Sept 2012

Introduced: 28 Sep 2012

CVE-2012-3492  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade Debian:13 condor to version 7.8.2~dfsg.1-1+deb7u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream condor package and not the condor package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

The filesystem authentication (condor_io/condor_auth_fs.cpp) in Condor 7.6.x before 7.6.10 and 7.8.x before 7.8.4 uses authentication directories even when they have weak permissions, which allows remote attackers to impersonate users by renaming a user's authentication directory.

CVSS Base Scores

version 3.1