Improper Input Validation Affecting condor package, versions <8.6.8~dfsg.1-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.68% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-CONDOR-6150730
  • published11 Jan 2024
  • disclosed5 Jul 2018

Introduced: 5 Jul 2018

CVE-2017-16816  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:13 condor to version 8.6.8~dfsg.1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream condor package and not the condor package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

The condor_schedd component in HTCondor before 8.6.8 and 8.7.x before 8.7.5 allows remote authenticated users to cause a denial of service (daemon crash) by leveraging use of GSI and VOMS extensions.