Improper Input Validation Affecting condor package, versions <8.0.5~dfsg.1-1


Severity

Recommended
0.0
low
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.64% (74th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-CONDOR-6150752
  • published11 Jan 2024
  • disclosed11 Oct 2013

Introduced: 11 Oct 2013

CVE-2013-4255  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:13 condor to version 8.0.5~dfsg.1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream condor package and not the condor package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

The policy definition evaluator in Condor 7.5.4, 8.0.0, and earlier does not properly handle attributes in a (1) PREEMPT, (2) SUSPEND, (3) CONTINUE, (4) WANT_VACATE, or (5) KILL policy that evaluate to an Unconfigured, Undefined, or Error state, which allows remote authenticated users to cause a denial of service (condor_startd exit) via a crafted job.

CVSS Base Scores

version 3.1