Double Free Affecting cvs package, versions <1.11.2-5.1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
23.87% (98th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-CVS-5674179
  • published7 Feb 2003
  • disclosed7 Feb 2003

Introduced: 7 Feb 2003

CVE-2003-0015  (opens in a new tab)
CWE-415  (opens in a new tab)

How to fix?

Upgrade Debian:13 cvs to version 1.11.2-5.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cvs package and not the cvs package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

Double-free vulnerability in CVS 1.11.4 and earlier allows remote attackers to cause a denial of service and possibly execute arbitrary code via a malformed Directory request, as demonstrated by bypassing write checks to execute Update-prog and Checkin-prog commands.

CVSS Base Scores

version 3.1