Arbitrary Code Injection Affecting devscripts package, versions <2.13.8


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.9% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-DEVSCRIPTS-5674339
  • published13 Dec 2013
  • disclosed13 Dec 2013

Introduced: 13 Dec 2013

CVE-2013-7050  (opens in a new tab)
CWE-94  (opens in a new tab)

How to fix?

Upgrade Debian:13 devscripts to version 2.13.8 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream devscripts package and not the devscripts package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

The get_main_source_dir function in scripts/uscan.pl in devscripts before 2.13.8, when using USCAN_EXCLUSION, allows remote attackers to execute arbitrary commands via shell metacharacters in a directory name.

CVSS Base Scores

version 3.1