Improper Input Validation Affecting devscripts package, versions <2.12.3


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.51% (71st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-DEVSCRIPTS-5674351
  • published1 Oct 2012
  • disclosed1 Oct 2012

Introduced: 1 Oct 2012

CVE-2012-2241  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:13 devscripts to version 2.12.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream devscripts package and not the devscripts package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

scripts/dget.pl in devscripts before 2.12.3 allows remote attackers to delete arbitrary files via a crafted (1) .dsc or (2) .changes file, probably related to a NULL byte in a filename.

CVSS Base Scores

version 3.1