Improper Input Validation Affecting devscripts package, versions <2.13.9


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.46% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-DEVSCRIPTS-5674422
  • published14 Dec 2013
  • disclosed14 Dec 2013

Introduced: 14 Dec 2013

CVE-2013-7085  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:13 devscripts to version 2.13.9 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream devscripts package and not the devscripts package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

Uscan in devscripts 2.13.5, when USCAN_EXCLUSION is enabled, allows remote attackers to delete arbitrary files via a whitespace character in a filename.

CVSS Base Scores

version 3.1