Arbitrary Argument Injection Affecting electrum package, versions <4.3.2+dfsg1-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.82% (57th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-ELECTRUM-21762775
  • published28 Oct 2026
  • disclosed17 Jun 2022

Introduced: 17 Jun 2022

CVE-2022-31246  (opens in a new tab)
CWE-88  (opens in a new tab)

How to fix?

Upgrade Debian:13 electrum to version 4.3.2+dfsg1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream electrum package and not the electrum package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

paymentrequest.py in Electrum before 4.2.2 allows a file:// URL in the r parameter of a payment request (e.g., within QR code data). On Windows, this can lead to capture of credentials over SMB. On Linux and UNIX, it can lead to a denial of service by specifying the /dev/zero filename.

CVSS Base Scores

version 3.1