Directory Traversal Affecting grunt package, versions <1.5.2-2


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.59% (47th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-GRUNT-5681888
  • published14 Apr 2022
  • disclosed12 Apr 2022

Introduced: 12 Apr 2022

CVE-2022-0436  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Debian:13 grunt to version 1.5.2-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream grunt package and not the grunt package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

Path Traversal in GitHub repository gruntjs/grunt prior to 1.5.2.

CVSS Base Scores

version 3.1