Improper Input Validation Affecting httpx package, versions <0.23.0-1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.12% (82nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-HTTPX-5682289
  • published29 Apr 2022
  • disclosed28 Apr 2022

Introduced: 28 Apr 2022

CVE-2021-41945  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:13 httpx to version 0.23.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream httpx package and not the httpx package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

Encode OSS httpx < 0.23.0 is affected by improper input validation in httpx.URL, httpx.Client and some functions using httpx.URL.copy_with.

CVSS Base Scores

version 3.1