Memory Leak Affecting libmatio package, versions <1.5.22-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.7% (52nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-LIBMATIO-5684347
  • published29 Apr 2022
  • disclosed2 May 2022

Introduced: 29 Apr 2022

CVE-2022-1515  (opens in a new tab)
CWE-401  (opens in a new tab)

How to fix?

Upgrade Debian:13 libmatio to version 1.5.22-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libmatio package and not the libmatio package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

A memory leak was discovered in matio 1.5.21 and earlier in Mat_VarReadNextInfo5() in mat5.c via a crafted file. This issue can potentially result in DoS.

CVSS Base Scores

version 3.1