Use After Free Affecting libsass package, versions <3.5.5-3


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.84% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-LIBSASS-5685239
  • published26 May 2018
  • disclosed26 May 2018

Introduced: 26 May 2018

CVE-2018-11499  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Debian:13 libsass to version 3.5.5-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsass package and not the libsass package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

A use-after-free vulnerability exists in handle_error() in sass_context.cpp in LibSass 3.4.x and 3.5.x through 3.5.4 that could be leveraged to cause a denial of service (application crash) or possibly unspecified other impact.