Double Free Affecting libyang package, versions <1.0.176-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.84% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-LIBYANG-8366688
  • published12 Nov 2024
  • disclosed22 Jan 2020

Introduced: 22 Jan 2020

CVE-2019-20393  (opens in a new tab)
CWE-415  (opens in a new tab)

How to fix?

Upgrade Debian:13 libyang to version 1.0.176-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libyang package and not the libyang package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

A double-free is present in libyang before v1.0-r1 in the function yyparse() when an empty description is used. Applications that use libyang to parse untrusted input yang files may be vulnerable to this flaw, which would cause a crash or potentially code execution.

CVSS Base Scores

version 3.1