Out-of-Bounds Affecting lua5.2 package, versions <5.2.3-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
12.03% (97th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-LUA52-5688702
  • published4 Sept 2014
  • disclosed4 Sept 2014

Introduced: 4 Sep 2014

CVE-2014-5461  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Debian:13 lua5.2 to version 5.2.3-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lua5.2 package and not the lua5.2 package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

Buffer overflow in the vararg functions in ldo.c in Lua 5.1 through 5.2.x before 5.2.3 allows context-dependent attackers to cause a denial of service (crash) via a small number of arguments to a function with a large number of fixed arguments.

CVSS Base Scores

version 3.1