Out-of-bounds Write Affecting mapserver package, versions <8.4.0-4+deb13u2


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.22% (69th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-MAPSERVER-15805460
  • published29 Mar 2026
  • disclosed27 Mar 2026

Introduced: 27 Mar 2026

CVE-2026-33721  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Debian:13 mapserver to version 8.4.0-4+deb13u2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mapserver package and not the mapserver package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

MapServer is a system for developing web-based GIS applications. Starting in version 4.2 and prior to version 8.6.1, a heap-buffer-overflow write in MapServer’s SLD (Styled Layer Descriptor) parser lets a remote, unauthenticated attacker crash the MapServer process by sending a crafted SLD with more than 100 Threshold elements inside a ColorMap/Categorize structure (commonly reachable via WMS GetMap with SLD_BODY). Version 8.6.1 patches the issue.

CVSS Base Scores

version 3.1