Improper Input Validation Affecting mapserver package, versions <5.2.2-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.13% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-MAPSERVER-5688864
  • published31 Mar 2009
  • disclosed31 Mar 2009

Introduced: 31 Mar 2009

CVE-2009-0843  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:13 mapserver to version 5.2.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mapserver package and not the mapserver package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

The msLoadQuery function in mapserv in MapServer 4.x before 4.10.4 and 5.x before 5.2.2 allows remote attackers to determine the existence of arbitrary files via a full pathname in the queryfile parameter, which triggers different error messages depending on whether this pathname exists.

CVSS Base Scores

version 3.1